Back to vendor advisories
Palo Alto Networks Security AdvisoriesCVE-2026-0297

CVE-2026-0297: GlobalProtect App: Buffer Overflow Vulnerability during UDP Tunnel Handshake

HighVendor CVSS 7.7 / 10 1 CVE Published Aug 12, 2026 at 4:00 PM UTC

Summary

A buffer overflow vulnerability exists in the Palo Alto Networks GlobalProtect™ app that enables a man-in-the-middle (MitM) attacker or a rogue gateway to disrupt system processes and potentially execute arbitrary code with elevated privileges (SYSTEM privileges on Windows, and root privileges on macOS and Linux).

Products covered

  • GlobalProtect App

  • GlobalProtect App 6.3

  • GlobalProtect App 6.2

  • GlobalProtect App 6.0

Remediation

Version

Minor Version

Suggested Solution

GlobalProtect App 6.3/6.2 on Linux

6.2.0 through 6.3.3-h14

Upgrade to 6.3.3-h15 or later.

GlobalProtect App 6.0 on Linux

6.0.0 through 6.0.14

Upgrade to 6.0.15 or later.

GlobalProtect App 6.3 on macOS

6.3.0 through 6.3.3-h13

Upgrade to 6.3.3-h14 (6.3.3-1121) or later.

GlobalProtect App 6.2 on macOS

6.2.0 through 6.2.8-h12

Upgrade to 6.2.8-h13 (6.2.8-1045) or later.

GlobalProtect App 6.0 on macOS

6.0.0 through 6.0.14

Upgrade to 6.0.15 or later.

GlobalProtect App 6.3 on Windows

6.3.0 through 6.3.3-h13

Upgrade to 6.3.3-h14 (6.3.3-1121) or later.

GlobalProtect App 6.2 on Windows

6.2.0 through 6.2.8-h12

Upgrade to 6.2.8-h13 (6.2.8-1045) or later.

GlobalProtect App 6.0 on Windows

6.0.0 through 6.0.14

Upgrade to 6.0.15 or later.

GlobalProtect App 6.3/6.1 on iOS

6.1.0 through 6.3.4

Upgrade to 6.3.5 or later.

GlobalProtect App 6.0 on iOS

6.0.0 through 6.0.14

Upgrade to 6.0.15 or later.

GlobalProtect App 6.3/6.1 on Android

6.1.0 through 6.3.4

Upgrade to 6.3.5 or later.

GlobalProtect App 6.0 on Android

6.0.0 through 6.0.14

Upgrade to 6.0.15 or later.

GlobalProtect App 6.3/6.1 on ChromeOS

6.1.0 through 6.3.4

Upgrade to 6.3.5 or later.

GlobalProtect App 6.0 on ChromeOS

6.0.0 through 6.0.14

Upgrade to 6.0.15 or later.

Vendor-listed fixes

  • GlobalProtect App 6.3 >= 6.3.3-h15 on Linux (ETA: 09/17), >= 6.3.3-h14 on macOS, >= 6.3.3-h14 on Windows, >= 6.3.5 on iOS, >= 6.3.5 on Android, >= 6.3.5 on Chrome OS

  • GlobalProtect App 6.2 None on Linux, >= 6.2.8-h13 on macOS, >= 6.2.8-h13 on Windows

  • GlobalProtect App 6.0 >= 6.0.15 on Linux (ETA: 10/29), >= 6.0.15 on macOS (ETA: 10/29), >= 6.0.15 on Windows (ETA: 10/29), >= 6.0.15 on iOS (ETA: 10/29), >= 6.0.15 on Android (ETA: 1

CVEs in this advisory 1

Update history

What changed in later vendor updates

SecurityAlert records field-level changes from the point we begin following a bulletin. Earlier vendor changes may not have a field-by-field record.

    • Added fixed versions: GlobalProtect App 6.0 >= 6.0.15 on Linux (ETA: 10/29), >= 6.0.15 on macOS (ETA: 10/29), >= 6.0.15 on Windows (ETA: 10/29), >= 6.0.15 on iOS (ETA: 10/29), >= 6.0.15 on Android (ETA: 1, GlobalProtect App 6.2 None on Linux....
    • Removed fixed versions: GlobalProtect App 6.0 >= 6.0.15 on Linux (ETA: 08/31), >= 6.0.15 on macOS (ETA: 08/31), >= 6.0.15 on Windows (ETA: 08/31), >= 6.0.15 on iOS (ETA: 08/31), >= 6.0.15 on Android (ETA: 0, GlobalProtect App 6.2 None on Linux....

Updates

  1. Published by Palo Alto Networks

    The publication date reported by the vendor.

  2. Added to SecurityAlert

    We collected the advisory from the official source.

  3. Updated by Palo Alto Networks

    The vendor changed the advisory after it was first published.

  4. Confirmed at the source

    Our collector saw this advisory during a later source check.