Back to vendor advisories
Palo Alto Networks Security AdvisoriesCVE-2026-0250

CVE-2026-0250: GlobalProtect App: Buffer Overflow Vulnerability during connection to Portal or Gateway

HighVendor CVSS 7.7 / 10 1 CVE Published May 13, 2026 at 4:00 PM UTC

Summary

A buffer overflow vulnerability exists in the Palo Alto Networks GlobalProtect™ app that enables a man in the middle attacker to disrupt system processes and potentially execute arbitrary code with SYSTEM privileges. This vulnerability is triggered during the processing of requests and responses exchanged between Portal and Gateway.

The GlobalProtect app on iOS is not affected.

Products covered

  • GlobalProtect App

  • GlobalProtect UWP App

  • GlobalProtect App 6.3

  • GlobalProtect App 6.2

  • GlobalProtect App 6.1

  • GlobalProtect App 6.0

  • GlobalProtect UWP App 6.3

Remediation

Version

Minor Version

Suggested Solution

GlobalProtect App 6.3 on Windows

6.3.0 through 6.3.3-h8

Upgrade to 6.3.3-h9 (6.3.3-999) or later.

GlobalProtect App 6.2 on Windows

6.2.0 through 6.2.8-h9

Upgrade to 6.2.8-h10 (6.2.8-948) or later.

GlobalProtect App 6.0 on Windows

6.0.0 through 6.0.12

Upgrade to 6.0.13 or later.

GlobalProtect App 6.0 on Linux

6.0.0 through 6.0.14

Upgrade to 6.0.15 or later.

GlobalProtect App 6.2/6.3 on Linux

6.2.0 through 6.3.3-h14

Upgrade to 6.3.3-h15 or later.

GlobalProtect App 6.3 on macOS

6.3.0 through 6.3.3-h8

Upgrade to 6.3.3-h9 (6.3.3-999) or later.

GlobalProtect App 6.2 on macOS

6.2.0 through 6.2.8-h9

Upgrade to 6.2.8-h10 (6.2.8-948) or later.

GlobalProtect App 6.0 on macOS

6.0.0 through 6.0.12

Upgrade to 6.0.13 or later.

GlobalProtect App 6.3 on Android

6.3.0 through 6.3.4

Upgrade to 6.3.5 or later.

GlobalProtect App 6.1 on Android

6.1.0 through 6.1.13

Upgrade to 6.1.14 or 6.3.4 or later.

GlobalProtect App 6.0 on Android

6.0.0 through 6.0.13

Upgrade to 6.0.14 or 6.1.14 or 6.3.4 or later.

GlobalProtect App 6.3 on ChromeOS

6.3.0 through 6.3.4

Upgrade to 6.3.5 or later.

GlobalProtect App 6.1 on ChromeOS

6.1.0 through 6.1.13

Upgrade to 6.1.14 or 6.3.4 or later.

GlobalProtect App 6.0 on ChromeOS

6.0.0 through 6.0.13

Upgrade to 6.0.14 or 6.1.14 or 6.3.4 or later.

GlobalProtect UWP App

6.1.0 through 6.3.3-h9

Upgrade to 6.3.3-h10 or later.

GlobalProtect App on iOS

No action needed

Vendor-listed fixes

  • GlobalProtect App 6.3 >= 6.3.3-h9 on Windows, >= 6.3.3-h9 on macOS, >= 6.3.5 on Android, >= 6.3.5 on ChromeOS, >= 6.3.3-h15 on Linux (ETA: 10/06)

  • GlobalProtect App 6.2 >= 6.2.8-h10 on Windows, >= 6.2.8-h10 on macOS

  • GlobalProtect App 6.1 >= 6.1.14 on Android, >= 6.1.14 on ChromeOS

  • GlobalProtect App 6.0 >= 6.0.15 on Linux (ETA: 10/29), >= 6.0.13 on Windows, >= 6.0.13 on macOS, >= 6.0.15 on Android (ETA: 10/29), >= 6.0.15 on ChromeOS (ETA: 10/29)

  • GlobalProtect UWP App 6.3 >= 6.3.3-h10 on Windows

  • GlobalProtect App All on iOS

CVEs in this advisory 1

Update history

What changed in later vendor updates

SecurityAlert records field-level changes from the point we begin following a bulletin. Earlier vendor changes may not have a field-by-field record.

    • Added fixed versions: GlobalProtect App 6.3 >= 6.3.3-h9 on Windows, >= 6.3.3-h9 on macOS, >= 6.3.5 on Android, >= 6.3.5 on ChromeOS, >= 6.3.3-h15 on Linux (ETA: 10/06).
    • Removed fixed versions: GlobalProtect App 6.3 >= 6.3.3-h9 on Windows, >= 6.3.3-h9 on macOS, >= 6.3.5 on Android, >= 6.3.5 on ChromeOS, >= 6.3.3-h15 on Linux (ETA: 09/17).

Updates

  1. Published by Palo Alto Networks

    The publication date reported by the vendor.

  2. Added to SecurityAlert

    We collected the advisory from the official source.

  3. Updated by Palo Alto Networks

    The vendor changed the advisory after it was first published.

  4. Confirmed at the source

    Our collector saw this advisory during a later source check.