AWS Security Bulletins guidance
Vendor revision: Oct 25, 2026A fix for this issue has been released and we recommend users of DJL upgrade to version 0.37.0 or later.
Vulnerability intelligence
CVE-2026-85228 and is rated Critical severity with a CVSS score of 9.1. It is not in the current CISA KEV record we collected. That does not prove exploitation has not occurred.
A fix for this issue has been released and we recommend users of DJL upgrade to version 0.37.0 or later.
An integer overflow in the tensor buffer validation component in Amazon Deep Java Library (DJL) from 0.13.0 through 0.36.0 on all platforms might allow a remote unauthenticated actor to obtain information from adjacent process memory or cause a denial of service via a crafted tensor payload.
To remediate this issue, users should upgrade to version 0.37.0 or above.
Source: NVD