AWS Security Bulletins guidance
Vendor revision: Oct 19, 2026Both issues are remediated in Language Servers for AWS version 1.69.0.
Vulnerability intelligence
CVE-2026-12957 and is rated High severity with a CVSS score of 7.8. It is not in the current CISA KEV record we collected. That does not prove exploitation has not occurred.
Both issues are remediated in Language Servers for AWS version 1.69.0.
Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed.
This issue requires the user to trust the workspace when prompted.
To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.
Source: NVD