Back to vendor advisories
Palo Alto Networks Security AdvisoriesCVE-2026-0310

CVE-2026-0310: PAN-OS: Buffer Overflow Vulnerability via XML Processing

CriticalVendor CVSS 9.2 / 10 1 CVE Published Sep 9, 2026 at 4:00 PM UTC

Summary

A buffer overflow vulnerability in the XML processing functionality of Palo Alto Networks PAN-OS® software enables an unauthenticated attacker with network access to the management web or dataplane interface to cause a denial of service (DoS) condition on VM-Series firewalls or execute arbitrary code with root privileges on the PA-Series firewalls.

Panorama is impacted by this vulnerability.

Products covered

  • Cloud NGFW

  • PAN-OS

  • Prisma Access

  • PAN-OS 12.2

  • PAN-OS 12.1

  • PAN-OS 11.2

  • PAN-OS 11.1

  • PAN-OS 10.2

Show 3 more products
  • Prisma Access 12.1

  • Prisma Access 11.2

  • Prisma Access 10.2

Remediation

Version

Minor Version

Suggested Solution

Cloud NGFW

Customers who prefer to upgrade can work with Palo Alto Networks support to schedule an on-demand software upgrade.

PAN-OS 12.2

12.2.0 through 12.2.2

Upgrade to 12.2.3 or later.

PAN-OS 12.1

12.1.8 through 12.1.9

Upgrade to 12.1.10 or later.

12.1.5 through 12.1.7-h*

Upgrade to 12.1.7-h5 or 12.1.10 or later.

12.1.2 through 12.1.4-h*

Upgrade to 12.1.4-h10 or 12.1.10 or later.

PAN-OS 11.2

11.2.11 through 11.2.13-h*

Upgrade to 11.2.13-h2 or later.

11.2.8 through 11.2.10-h*

Upgrade to 11.2.10-h14 or later.

11.2.5 through 11.2.7-h*

Upgrade to 11.2.7-h20 or later.

11.2.0 through 11.2.4-h*

Upgrade to 11.2.4-h21 or later.

PAN-OS 11.1

11.1.14 through 11.1.16-h*

Upgrade to 11.1.16-h2 or later.

11.1.11 through 11.1.13-h*

Upgrade to 11.1.13-h12 or later.

11.1.8 through 11.1.10-h*

Upgrade to 11.1.10-h33 or later.

11.1.7 through 11.1.7-h*

Upgrade to 11.1.7-h10 or later.

11.1.5 through 11.1.6-h*

Upgrade to 11.1.6-h38 or later.

11.1.0 through 11.1.4-h*

Upgrade to 11.1.4-h36 or later.

PAN-OS 10.2

10.2.17 through

10.2.18-h*

Upgrade to 10.2.18-h10 or later.

10.2.14 through 10.2.16-h*

Upgrade to 10.2.16-h10 or later.

10.2.11 through 10.2.13-h*

Upgrade to 10.2.13-h24 or later.

10.2.8 through 10.2.10-h*

Upgrade to 10.2.10-h40 or later.

10.2.0 through 10.2.7-h*

Upgrade to 10.2.7-h37 or later.

All older

unsupported

PAN-OS versions

Upgrade to a supported fixed version.

Prisma Access 12.1

12.1.2 through 12.1.*

Upgrade to 12.1.7-h5 or later.

Prisma Access 11.2

11.2.0 through 11.2*

Upgrade to 11.2.7-h20 or later.

Prisma Access 10.2

10.2.0 through 10.2.*

Upgrade to 10.2.10-h40 or later.

* See the note under Product Status for information regarding Prisma Access and Cloud NGFW upgrades.

Vendor-listed fixes

  • Cloud NGFW None on AWS*, None on Azure*

  • PAN-OS 12.2 >= 12.2.3

  • PAN-OS 12.1 >= 12.1.4-h10, >= 12.1.7-h5, >= 12.1.10

  • PAN-OS 11.2 >= 11.2.4-h21, >= 11.2.7-h20, >= 11.2.10-h14, >= 11.2.13-h2

  • PAN-OS 11.1 >= 11.1.4-h36, >= 11.1.6-h38, >= 11.1.7-h10, >= 11.1.10-h33, >= 11.1.13-h12, >= 11.1.16-h2

  • PAN-OS 10.2 >= 10.2.7-h37, >= 10.2.10-h40, >= 10.2.13-h24, >= 10.2.16-h10, >= 10.2.18-h10

  • Prisma Access 12.1 >= 12.1.7-h5*

  • Prisma Access 11.2 >= 11.2.7-h20*

Show 1 more fixes
  • Prisma Access 10.2 >= 10.2.10-h40*

CVEs in this advisory 1

Update history

What changed in later vendor updates

SecurityAlert records field-level changes from the point we begin following a bulletin. Earlier vendor changes may not have a field-by-field record.

    • The vendor changed the advisory summary.
    • The vendor changed its remediation guidance.

Updates

  1. Published by Palo Alto Networks

    The publication date reported by the vendor.

  2. Added to SecurityAlert

    We collected the advisory from the official source.

  3. Confirmed at the source

    Our collector saw this advisory during a later source check.