Summary
A stored cross-site scripting (XSS) vulnerability in Palo Alto Networks PAN-OS® software enables a malicious authenticated administrator to store or execute a JavaScript payload using the web interface.
This issue is applicable to PAN-OS software on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series).
Cloud NGFW and Prisma® Access are not affected by this vulnerability.
Products covered
Cloud NGFW
PAN-OS
Prisma Access
PAN-OS 12.2
PAN-OS 12.1
PAN-OS 11.2
PAN-OS 11.1
Remediation
Version | Minor Version | Suggested Solution |
|---|---|---|
Cloud NGFW | No action needed. | |
PAN-OS 12.2 | No action needed. | |
PAN-OS 12.1 | 12.1.2 through 12.1.9 | Upgrade to 12.1.10 or later. |
PAN-OS 11.2 | 11.2.0 through 11.2.13 | Upgrade to 11.2.13-h2 or later. |
PAN-OS 11.1 | 11.1.0 through 11.1.16 | Upgrade to 11.1.16-h2 or later. |
All older unsupported PAN-OS versions | Upgrade to a supported fixed version. | |
Prisma Access | No action needed. |
Vendor-listed fixes
Cloud NGFW All
PAN-OS 12.2 All
PAN-OS 12.1 >= 12.1.10
PAN-OS 11.2 >= 11.2.13-h2
PAN-OS 11.1 >= 11.1.16-h2
Prisma Access All
CVEs in this advisory 1
Updates
- Published by Palo Alto Networks
The publication date reported by the vendor.
- Added to SecurityAlert
We collected the advisory from the official source.
- Confirmed at the source
Our collector saw this advisory during a later source check.